Владельцы сайтов под управлением WordPress, использующие устаревшую версию PHP, увидят призыв обновиться в панели управления CMS. Объявление со ссылкой на специальную страницу поддержки получат администраторы, чей хостинг работает на версии скриптового языка 5.6 и ранее. Авторы системы управления сайтами намерены перевести все WordPress-ресурсы на актуальные варианты PHP к декабрю 2019 года.

Разработчики WordPress планируют изменить минимальные требования к установке платформы и проверять наличие PHP 5.6 с апреля, а PHP 7.0 — с декабря 2019 года. Предупреждение об устаревшем движке появится в очередном релизе CMS, который запланирован на 21 февраля. Команда сервиса подготовила для владельцев сайтов рекомендации по самостоятельному обновлению PHP, однако хостинг-провайдеры могут заменить ссылку в объявлении на адрес своей техподдержки.

По данным специалистов, 85% пользователей WordPress версии 5.0 используют PHP 5.6 или новее, однако в сети по-прежнему остается немало сайтов, чьи владельцы не обновили CMS и не увидят предупреждение. Учитывая это, разработчики платформы прилагают значительные усилия для исправления ситуации. Служба автоматического обновления движка, впервые появившаяся в релизе 3.7, призвана устанавливать новые версии при минимальном участии администратора, а специальные уведомления в Google Search Console напоминают хозяину ресурса о необходимости апдейта.

Срок поддержки PHP 5.6 закончился 1 января 2019 года, а обслуживание версии 7.0 прекращено 3 декабря 2018-го. Это означает, что создатели более не будут выпускать обновления безопасности для этих вариантов скриптового языка. В данный момент разработчики активно развивают лишь две сборки PHP: версию 7.2, чья поддержка полностью закончится 30 ноября 2020-года, и выпущенный чуть больше месяца назад релиз 7.3. Пользователи платформ, использующих PHP 7.1, будут получать патчи с исправлениями багов до декабря 2019 года.

Категории: Главное, Кибероборона